我真是哭了,其實第一遍就是可以的,但是我忘了double在輸入輸出是不同的了,我統統寫成%lf,真是失誤呀。

一開始滿分25,拿了21分。

然後我看了一下沒通過的測試點,發現都是佔用內存很大的。所以我大膽猜測可能有一條鏈跑到頭,節點個數是100000的情況。

所以我修改了一下我的minDepth,就滿分啦。

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from ones supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10?5??), the total number of the members in the supply chain (and hence their IDs are numbered from 0 to N?1, and the root suppliers ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K?i?? ID[1] ID[2] ... ID[K?i??]

where in the i-th line, K?i?? is the total number of distributors or retailers who receive products from supplier i, and is then followed by the IDs of these distributors or retailers. K?j?? being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 10?10??.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0

Sample Output:

1.8362 2

代碼:

#include <cstdio>
#include <vector>
using namespace std;

vector<int> tree[100005];

double MIN = 9999999;
int num = 0;
int minDepth;

void dfs(int root, int depth, double p, double r) {
int len = tree[root].size();
if(len == 0) {
if(depth < minDepth) {
minDepth = depth;
num = 1;
MIN = p;
}
else if(depth == minDepth) {
num++;
}
return;
}
else {
for(int i = 0; i < len; i++) {
dfs(tree[root][i], depth + 1, p * r, r);
}
}
}

int main() {
int n;
double p;
double r;
scanf("%d %lf %lf", &n, &p, &r);
for(int i = 0; i < n; i++) {
int k, a;
scanf("%d", &k);
for(int j = 0; j < k; j++) {
scanf("%d", &a);
tree[i].push_back(a);
}
}
r = 1 + (r / 100);
minDepth = n + 1;
dfs(0, 1, p, r);
printf("%.4f %d", MIN, num);
return 0;
}

推薦閱讀:

相關文章